Jumat, 23 Oktober 2020

Lab 7. BGP Attribute (Origin)

 Lab 7. BGP Attribute (Origin)


R1

R1(config)#router rip

R1(config-router)#ver 2

R1(config-router)#net 11.11.11.11

R1(config-router)#no auto-summary

R1(config-router)#router bgp 1234

R1(config-router)#redistribute rip

R1(config-router)#no neighbor 4.4.4.4 remote-as 1234

R1(config-router)#exit


R3

R3(config)#router bgp 1234

R3(config-router)#neighbor 34.34.34.4 remote-as 4

R3(config-router)#neighbor 1.1.1.1 next-hop-self

R3(config-router)#exit


R4

R4(config)#no router bgp 1234

R4(config)#router bgp 4

R4(config-router)#neighbor 34.34.34.3 remote-as 1234

R4(config-router)#net 44.44.44.44 mask 255.255.255.255

R4(config-router)#exit


Pengecekan


R3

R3(config)#do show ip bgp

BGP table version is 6, local router ID is 3.3.3.3

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

             r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

    

   Network         Next Hop             Metric  LocPrf Weight  Path

*>i11.11.11.11/32    1.1.1.1                   0    100      0 ?

*> 44.44.44.44/32   34.34.34.4            0             0 4 i


Penting di ingat!!!!

i = route yang berasal dari BGP (eBGP/iBGP) yang diadvertise melalui perintah
network x.x.x mask y.y.y.y

e = route yang berasal dari protocol EGP (saat ini sudah tidak ada protocol tsb)

? = route yang berasal dari protocol lain (Static/RIP/OSPF/EIGRP) yang
diredistribute kedalam BGP.

  • R3 untuk menuju network 11.11.11.11/32 ada code “ ?” nilai origin dariroutenya adalah “?” karena berasal dari protocol routing RIP yang diredistribute kedalam BGP
  • R3 untuk menuju network 44.44.44.44/32 adalah via “4 i” yang artinya Next AS Pathnya adalah AS 4 dan nilai origin dari routenya adalah 









Kamis, 22 Oktober 2020

LAB 6. BGP Route Reflector

 LAB 6. BGP Route Reflector


Pada i-BGP peernya harus full mesh ,maksudnya yaitu 
• R1 peers ke R2, R3, R4 
• R2 peers ke R1, R3, R4 
• R3 peers ke R1, R2, R4 
• R4 peers ke R1, R2, R3

Hapus konfigurasi BGP pada lab sebelumnya dan tambahkan 1 router baru.


R1 dan R2 

R1(config)#no router bgp 12 
R2(config)#no router bgp 12 


R3 

R3(config)#no router bgp 3 


Sekarang kita akan mengkonfigurasi IP pada R3 dan R4 


R3 

R3(config)#int f1/0 
R3(config-if)#ip add 34.34.34.3 255.255.255.0 
R3(config-if)#no shutdown 


R4 

R4(config)#int f0/0 
R4(config-if)#ip address 34.34.34.4 255.255.255.0 
R4(config-if)#no shutdown 
R4(config-if)#exit 
R4(config)#int lo0 
R4(config-if)#ip add 4.4.4.4 255.255.255.255 
R4(config-if)#exit 


Kita konfigurasi BGP dan EIGRP pada masing-masing router 


R1 

R1(config)#router eigrp 10 
R1(config-router)#network 1.1.1.1 0.0.0.0 
R1(config-router)#network 12.12.12.1 0.0.0.0 
R1(config-router)#no auto-summary 
R1(config-router)#exit 
R1(config)#router bgp 1234 
R1(config-router)#neighbor 2.2.2.2 remote-as 1234 
R1(config-router)#neighbor 2.2.2.2 update lo0 
R1(config-router)#neighbor 2.2.2.2 route-reflector-client 
R1(config-router)#neighbor 3.3.3.3 remote-as 1234 
R1(config-router)#neighbor 3.3.3.3 update lo0 
R1(config-router)#neighbor 3.3.3.3 route-reflector-client 
R1(config-router)#neighbor 4.4.4.4 remote-as 1234 
R1(config-router)#neighbor 4.4.4.4 update lo0 
R1(config-router)#neighbor 4.4.4.4 route-reflector-client 
R1(config-router)#exit 


R2 

R2(config)#router eigrp 10 
R2(config-router)#network 2.2.2.2 0.0.0.0 
R2(config-router)#network 12.12.12.2 0.0.0.0 
R2(config-router)#network 23.23.23.2 0.0.0.0 
R2(config-router)#no auto-summary 
R2(config)#router bgp 1234 
R2(config-router)#neighbor 1.1.1.1 remote-as 1234 
R2(config-router)#neighbor 1.1.1.1 update-source lo0 
R2(config-router)#exit 


R3 

R3(config)#router eigrp 10 
R3(config-router)#network 23.23.23.3 0.0.0.0 
R3(config-router)#network 34.34.34.3 0.0.0.0 
R3(config-router)#network 3.3.3.3 0.0.0.0 
R3(config-router)#no auto-summary 
R3(config-router)#exit 
R3(config)#router bgp 1234 
R3(config-router)#neighbor 1.1.1.1 remote-as 1234 
R3(config-router)#neighbor 1.1.1.1 update-source lo0 


R4 

R4(config)#router eigrp 10 
R4(config-router)#network 4.4.4.4 0.0.0.0 
R4(config-router)#network 34.34.34.4 0.0.0.0 
R4(config-router)#no auto-summary 
R4(config-router)#exit 
R4(config)#router bgp 1234 
R4(config-router)#neighbor 1.1.1.1 remote-as 1234 
R4(config-router)#neighbor 1.1.1.1 update-source lo0 
R4(config-router)#exit 


Kita cek 


R1 

R1#sh ip bgp summary 
BGP router identifier 11.11.11.11, local AS number 1234 
BGP table version is 1, main routing table version 1

Neighbor      V           AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down 
State/PfxRcd 
2.2.2.2        4      1234         4       4      1     0  0 00:02:33      0 
3.3.3.3        4      1234         4       4      1     0 0 00:02:31       0 
 4.4.4.4       4      1234         4       4      1     0 0 00:02:34       0 


R2 

R2#sh ip bgp summary 
BGP router identifier 22.22.22.22, local AS number 1234 
BGP table version is 1, main routing table version 1 
 Neighbor        V        AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down 
State/PfxRcd 
1.1.1.1        4      1234       10     10         1   0   0 00:08:58    0  


Pengetesan, kita harus advertise suatu route di salah satu router dan kita pastikan bisa ping dari semua router. 


R4 

R4(config)#interface Loopback44 
R4(config-if)#ip address 44.44.44.44 255.255.255.255 
R4(config)#router bgp 1234 
R4(config-router)#network 44.44.44.44 mask 255.255.255.255 


Kita cek lagi pada setiap router mengenai route yang diadvertise oleh R4 


R1 

R1#sh ip bgp 44.44.44.44 
BGP routing table entry for 44.44.44.44/32, version 3 
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17)) 
Flag: 0x820 
  Advertised to update-groups: 
       1 
  Local, (Received from a RR-client)  
  4.4.4.4 (metric 161280) from 4.4.4.4 (44.44.44.44) 
    Origin IGP, metric 0, localpref 100, valid, internal, best 


R3 

R3#sh ip bgp 44.44.44.44 
BGP routing table entry for 44.44.44.44/32, version 3 
Paths: (1 available, best #1, table Default-IP-Routing-Table, RIB-failure(17)) 
Flag: 0x820 
 Not advertised to any peer 
 Local 
    4.4.4.4 (metric 156160) from 1.1.1.1 (11.11.11.11) 
      Origin IGP, metric 0, localpref 100, valid, internal, best 
      Originator: 44.44.44.44, Cluster list: 11.11.11.11 


Kita cek ping 


R2 

R2#ping 44.44.44.44 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/36 ms

Selasa, 20 Oktober 2020

LAB 5. BGP Authentication

 LAB 5. BGP Authentication



Konfigurasi BGP 


R1 

R1(config)#router bgp 12 
R1(config-router)#neighbor 12.12.12.2 password CCNPJOS 


R2 

R2(config)#router bgp 12 
R2(config-router)#neighbor 12.12.12.1 password CCNPJOS 


Kita cek


R1 

R1(config)#do sh ip bgp summary 
Neighbor           V              AS MsgRcvd MsgSent       TblVer     InQ  OutQ  Up/Down State/PfxRcd 
12.12.12.2      4         12             59            62                 5           0         0     00:00:31 
1

LAB 4. BGP Next-Hop-Self

 LAB 4. BGP Next-Hop-Self


Sebelumnya kita harus hapus terlebih dahulu konfigurasi routing BGP dan EIGRP pada lab sebelumnya. 


R1 dan R2 


R1(config)#no router bgp 12 
R1(config)#no router eigrp 10 


R3 

R3(config)#no router bgp 3 


Kita harus mengkonfigurasi BGP Peer melalui Physical Interface dan advertise satu network pada R3 


R1 

R1(config)#router bgp 12 
R1(config-router)#neighbor 12.12.12.2 remote-as 12 


R2 

R2(config)#router bgp 12 
R2(config-router)#neighbor 12.12.12.1 remote-as 12 
R2(config-router)#neighbor 23.23.23.3 remote-as 3 


R3 

R3(config)#router bgp 3 
R3(config-router)#neighbor 23.23.23.2 remote-as 12 
R3(config-router)#network 3.3.3.3 mask 255.255.255.255 


R1 

R1(config)#do show ip bgp 
BGP table version is 1, local router ID is 11.11.11.11 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
             r RIB-failure, S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 
   Network          Next Hop            Metric  LocPrf  Weight  Path 
* i3.3.3.3/32        23.23.23.3                0   100       0 3 i 


 Di sini kita tidak menemukan tanda (>) best pada route 3.3.3.3 yang dikarenakan nexthopnya tidak reachable.


R2 

R2(config)#router bgp 12 
R2(config-router)#neighbor 12.12.12.1 next-hop-self 


Sekarang kita cek lagi pada R1 


R1 

R1(config)#do show ip bgp 
Network            Next Hop            Metric LocPrf Weight Path 
*>i3.3.3.3/32       12.12.12.2              0   100      0 3 i 


Jika kita perhatikan ip next hopnya sudah berubah dari R3 menjadi R2 sehingga kita bisa melakukan ping dari R1 


R1 

R1(config)#do sh ip route bgp 
     3.0.0.0/32 is subnetted, 1 subnets 
B      3.3.3.3 [200/0] via 12.12.12.2, 00:05:17 


Kita bisa melakukan advertise ke salah satu ip R1 ke BGP untuk dijadikan sebagai source saat ping ke R3. 


R1 

R1(config)#router bgp 12 
R1(config-router)#network 1.1.1.1 mask 255.255.255.255  


hasil akhirnya sebagai berikut. 


R1 

R1#ping 3.3.3.3 source 1.1.1.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds: 
Packet sent with a source address of 1.1.1.1 
!!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 24/36/44 ms
















Senin, 19 Oktober 2020

LAB 3. eBGP Peering

LAB 3. eBGP Peering

 

Metode Lab

  • Konfigurasi pengalamatan IP sesuai topologi diatas
  • Konfigurasikan iBGP Peers antara R1 dan R2 
  • BGP Peersnya menggunakan IP Interface Physycalnya
  • Interface Loopback untuk diadvertise ke BGP
Peering BGP bisa menggunakan IP Interface physycal ataupun IP Loopback, umumnya pada iBGP menggunakan IP Loopback, sedangkan eBGP IP Interface Physical. Berikut kita belajar melakukan peering dari IP interface physical. Router R1 dan R2 



Kita konfigurasi terlebih dahulu IP address pada f1/0 di Router 2 


R2 

R2(config)#int f1/0 
R2(config-if)#ip add 23.23.23.2 255.255.255.0 
R2(config-if)#no shutdown 


Sekarang kita mengkonfigurasi IP Address pada router 3 


R3 

R3(config)#int f0/0 

R3(config-if)#ip add 23.23.23.3 255.255.255.0 
R3(config-if)#no shutdown 
R3(config-if)#exit 
R3(config)#int loopback0 
R3(config-if)#ip add 3.3.3.3 255.255.255.255 
R3(config-if)#exit 

Nah.. sekarang konfigurasi BGP 

R2 

R2(config)#router bgp 12 
R2(config-router)#neighbor 23.23.23.3 remote-as 3 

R3 

R3(config)#router bgp 3 
R3(config-router)#neighbor 23.23.23.2 remote-as 12 
R3(config-router)#network 3.3.3.3 mask 255.255.255.255  


Lalu cek BGP Peernya... 


R3 

R3#sh ip bgp summary 
BGP router identifier 3.3.3.3, local AS number 3 
BGP table version is 4, main routing table version 4 
3 network entries using 396 bytes of memory 
3 path entries using 156 bytes of memory 
4/3 BGP path/bestpath attribute entries using 672 bytes of memory 
1 BGP AS-PATH entries using 24 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory 
BGP using 1280 total bytes of memory 
BGP activity 3/0 prefixes, 3/0 paths, scan interval 60 secs 
Neighbor            V             AS MsgRcvd  MsgSent   TblVer    InQ  OutQ  Up/Down State/PfxRcd 
23.23.23.2     4        12     7      5         4   0     0 00:02:15     2 


Sekarang terlihat sudah ada 2 route 


R3 

R3#sh ip bgp 
BGP table version is 4, local router ID is 3.3.3.3 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
            r RIB-failure, S Stale '
Origin codes: i - IGP, e - EGP, ? - incomplete 


  Network                Next Hop            Metric LocPrf      Weight Path 
*> 3.3.3.3/32             0.0.0.0                   0                        32768 i 
*> 11.11.11.11/32     23.23.23.2                                         0 12 i 
*> 22.22.22.22/32    23.23.23.2             0                         0 12 i 


Sekarang kita cek dengan melakukan tes ping 


R3 

R3#ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds: 
..... 
Success rate is 0 percent (0/5) 


Tidak bisa di ping


R1

R1#sh ip bgp 
BGP table version is 3, local router ID is 11.11.11.11 
Status codes: s \uppressed, d damped, h history, * valid, > best, i - internal, 
             r RIB-failure, S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 
 

Network            Next Hop            Metric LocPrf Weight Path 
* i3.3.3.3/32       23.23.23.3              0   100      0 3 i 
*> 11.11.11.11/32     0.0.0.0                0        32768 i 
*>i22.22.22.22/32    2.2.2.2                0    100     0 i 


Sekarang kita cek routing table di R1 


R1 

R1#sh ip route bgp 
     22.0.0.0/32 is subnetted, 1 subnets 
B      22.22.22.22 [200/0] via 2.2.2.2, 03:05:04 


Sekarang kita bisa melihat bahwa tidak ada satupun route yang berasal dari R3 . 

Ada beberapa cara yang bisa kita lakukan, salah satunya yaitu mengadvertise network 
23.23.23.0 ke BGP pada R2. 

R2 

R2(config)#router bgp 12 
R2(config-router)#network 23.23.23.0 mask 255.255.255.0 


Sekarang kita cek lagi di R1 


R1 

R1#sh ip bgp 
BGP table version is 5, local router ID is 11.11.11.11 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
             r RIB-failure, S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete  


Network              Next Hop       Metric  LocPrf  Weight Path 
*>i3.3.3.3/32         23.23.23.3       0     100       0 3 i 
*> 11.11.11.11/32  0.0.0.0              0         32768 i 
*>i22.22.22.22/32 2.2.2.2              0    100       0 i 
*>i23.23.23.0/24  2.2.2.2              0    100       0 i   


Kita coba lakukan tes ping kembali dari R3


R3 

R3#ping 11.11.11.11 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/44 ms 


Akhirnya berhasil reply. Sekarang kita melakukan ping dari R1. 


R1 

R1#ping 3.3.3.3 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds: 
..... 
Success rate is 0 percent (0/5) 



R3 

R3#show ip route 
         3.0.0.0/32 is subnetted, 1 subnets 
C 3.3.3.3 is directly connected, Loopback0 
        11.0.0.0/32 is subnetted, 1 subnets 
11.11.11.11 [20/0] via 23.23.23.2, 00:10:51 
        22.0.0.0/32 is subnetted, 1 subnets 
B 22.22.22.22 [20/0] via 23.23.23.2, 00:10:51 
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
C 23.23.23.0/24 is directly connected, FastEthernet0/0 
L 23.23.23.3/32 is directly connected, FastEthernet0/0  


Setelah kita cek ternyata hanya ip 11.11.11.11 saja, maka gunakan sebagai sourcenya. 


R1 

R1#ping 3.3.3.3 source 11.11.11.11 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds: 
Packet sent with a source address of 11.11.11.11 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/44 ms 


Sekarang kita lakukan ping dengan cara yang sama,bisa dilakukan yaitu mengadvertise network 12.12.12.0 ke BGP pada R1. 


R1 

R1(config)#router bgp 12 
R1(config-router)#network 12.12.12.0 mask 255.255.255.0 


Cek R3 dahulu, pastikan network 12.12.12.0 terkenali 


R3 

R3#sh ip route bgp 
       22.0.0.0/32 is subnetted, 1 subnets 
B         22.22.22.22 [20/0] via 23.23.23.2, 02:28:19 
       11.0.0.0/32 is subnetted, 1 subnets 
B         11.11.11.11 [20/0] via 23.23.23.2, 02:28:19 
       12.0.0.0/24 is subnetted, 1 subnets 
B         12.12.12.0 [20/0] via 23.23.23.2, 00:01:51 


Setelah itu kita lakukan tes ping kembali pada R1 tanpa menggunakan source 


R1

R1(config)#do ping 3.3.3.3 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/35/40 ms 



Rabu, 14 Oktober 2020

Lab 2. iBGP Peering – Loopback

 Lab 2. iBGP Peering – Loopback


Sekarang kita akan melakukan Peer dengan IP loopback . Pastikan IP Loopbacknya harus bisa diping terlebih dahulu. Oh iya jgn lupa untuk menghapus konfigurasi sebelumnya, sebelum dilanjutkan ke konfigurasi berikutnya.

(Konfigurasi Peers BGP Internal menggunakan IP interface Loopback)

Metode Lab

  • Konfigurasi pengalamatan IP seperti diatas
  • Konfigurasi routing IGP RIP atau lainya agar loopbacknya reachable
  • Konfigurasi iBGP Peers menggunakan IP Loopbacknya
  • Membuat IP Loopback baru untuk diadvertise ke BGP
R1 & R2 

R1(config)#no router bgp 12 
R2(config)#no router bgp 12 

Agar loopbacknya bisa diping , gunakan IGP (RIP, OSPF, EIGRP) ataupun static route 

R1 

R1(config)#router eigrp 10 
R1(config-router)#network 1.1.1.1 0.0.0.0 
R1(config-router)#network 12.12.12.1 0.0.0.0 
R1(config-router)#no auto-summary 


R2 

R2(config)#router eigrp 10 
R2(config-router)#network 2.2.2.2 0.0.0.0 
R2(config-router)#network 12.12.12.2 0.0.0.0 
R2(config-router)#no auto-summary 


Pastikan IP Loopback nya HARUS bisa diping dulu


R1

R1(config)#do ping 2.2.2.2
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms

R2 

R2(config)#do ping 1.1.1.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms 


Konfigurasi BGP Peernya dengan menambahkan update-source loopback 0, jika tidak ditambahkan, maka yang digunakan updatenya adalah ip interface physical sehingga bpg adjencencynya akan bermasalah.  


R1 

R1(config)#router bgp 12 
R1(config-router)#neighbor 2.2.2.2 remote-as 12 
R1(config-router)#neighbor 2.2.2.2 update-source loopback 0 

R2 

R2(config)#router bgp 12 
R2(config-router)#neighbor 1.1.1.1 remote-as 12 
R2(config-router)#neighbor 1.1.1.1 update-source loopback 0 

Pastikan BGP adjacencynya sudah up 

R2 

R2(config)#do show ip bgp summary 
BGP router identifier 2.2.2.2, local AS number 12 
BGP table version is 1, main routing table version 1 
Neighbor            V             AS MsgRcvd MsgSent   TblVer    InQ  OutQ  Up/Down State/PfxRcd 
1.1.1.1        4           12    0       0        0   0   0 never   Active 

Pastikan pada bagian state/ PfxRcdnya bernilai 0. Perhatikan juga ip neighbornya bukan lagi ip physical melainkan ip loopbacknya. Kita buat ip loopback baru untuk diadvertise ke BGP 

Advertise network ke BGP
Buat interface loopback di masing masing router

R1 

R1(config)#int loopback 11 
R1(config-if)#ip add 11.11.11.11 255.255.255.255 
R1(config-if)#exit 
R1(config)#router bgp 12 
1(config-router)#network 11.11.11.11 mask 255.255.255.255 

R2 

R2(config)#int lo22 
R2(config-if)#ip add 22.22.22.22 255.255.255.255 
R2(config-if)#exit 
R2(config)#router bgp 12 
R2(config-router)#network 22.22.22.22 mask 255.255.255.255 

Kita harus pastikan route tersebut sudah diadvertise sehingga nilai State/PfxRcd nya menjadi 1

R1 

R1#sh ip bgp summary 
BGP router identifier 1.1.1.1, local AS number 12 
BGP table version is 3, main routing table version 3 
2 network entries using 264 bytes of memory 
2 path entries using 104 bytes of memory 
3/2 BGP path/bestpath attribute entries using 504 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory 
BGP using 904 total bytes of memory 
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor           V             AS MsgRcvd MsgSent   TblVer   InQ  OutQ  Up/Down State/PfxRcd 
2.2.2.2        4        12      8      8        3   0    0 00:05:39       1 

Cek route yang diadvertise ke BGP dan kemudian cek routing tabelnya

R1 

R1#sh ip bgp BGP table version is 3, local router ID is 1.1.1.1 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
             r RIB-failure, S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 
    Network         Next Hop            Metric LocPrf Weight Path 
*> 11.11.11.11/32     0.0.0.0                 0        32768 i 
*>i22.22.22.22/32    2.2.2.2                 0    100     0  i 

Sekarang kita cek routing tabelnya 

R1 

R1#sh ip route bgp 
     22.0.0.0/32 is subnetted, 1 subnets 
B       22.22.22.22 [200/0] via 2.2.2.2, 00:05:44



Selasa, 13 Oktober 2020

BGP (Border Gateway Protocol)

 BGP (Border Gateway Protocol)


Border Gateway Protocol (BGP) merupakan salah satu jenis routing protokol yang digunakan untuk koneksi antar Autonomous System (AS), dan salah satu jenis routing protokol yang banyak digunakan di ISP besar ataupun perbankan.BGP termasuk dalam kategori routing protokol jenis Exterior Gateway Protokol (EGP).

Dengan adanya EGP, router dapat melakukan pertukaran rute dari dan ke luar jaringan lokal Auotonomous System (AS). BGP mempunyai skalabilitas yang tinggi karena dapat melayani pertukaran routing pada beberapa organisasi besar. Oleh karena itu BGP dikenal dengan routing protokol yang sangat rumit dan kompleks.

Oke sekarang kita masuk ke lab bgp 1 ya.....


Lab 1. Konfigurasi Dasar iBGP Peering 



Untuk peering BGP, kita bisa menggunakan IP Loopback untuk iBGP dan Internal Physical untuk eBGP. Kita akan melakukan peering dari IP Inteface physical untuk membuat eBGP. Router R1 dan R2 harus dalam 1 AS number yang sama yakni AS 12.



R1 

R1(config)#int f0/0 
R1(config-if)#ip add 12.12.12.1 255.255.255.0 
R1(config-if)#no sh 
R1(config)#router bgp 12 
R1(config-router)#neighbor 12.12.12.2 remote-as 12 

R2 

R2(config)#int f0/0 
R2(config-if)#ip add 12.12.12.2 255.255.255.0 
R2(config-if)#no sh 
R2(config)#router bgp 12 
R2(config-router)#neighbor 12.12.12.1 remote-as 12 

Tunggu sampai beberapa saat hingga muncul seperti ini 
*Jul 18 13:59:08.511: %BGP-5-ADJCHANGE: neighbor 12.12.12.1 Up 

Verifikasi 

R1 

R1#sh ip bgp summary 
BGP router identifier 12.12.12.1, local AS number 12 
BGP table version is 1, main routing table version 1 
Neighbor        V       AS   MsgRcvd   MsgSent   TblVer   InQ   OutQ   Up/Down 
State/PfxRcd 
12.12.12.2    4     12      44         44             1     0      0     00:42:50       0  

Sekarang kita pastikan pada bagian State/PfxRcd terdapat nilainya walaupun 0. Selanjutnya kita akan coba lakukan advertise suatu route ke BGP

R1 

R1(config)#int lo0 
R1(config-if)#ip add 1.1.1.1 255.255.255.255 
R1(config)#router bgp 12 
R1(config-router)#network 1.1.1.1 mask 255.255.255.255 

R2 

R2(config)#int lo0 
R2(config-if)#ip add 2.2.2.2 255.255.255.255 
R2(config)#router bgp 12 
R2(config-router)#network 2.2.2.2 mask 255.255.255.255 

R1 

R1#ping 2.2.2.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/20 ms 

R1 

R1#sh ip bgp summary 
BGP router identifier 12.12.12.1, local AS number 12 
BGP table version is 3, main routing table version 3 
2 network entries using 264 bytes of memory 
2 path entries using 104 bytes of memory 
3/2 BGP path/bestpath attribute entries using 504 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory 
BGP using 904 total bytes of memory 
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor       V    AS   MsgRcvd   MsgSent   TblVer    InQ        OutQ   Up/Down 
State/PfxRcd 
12.12.12.2   4   12     98            98             3      0         0      01:36:38         1  

Sebelumnya pada bagian State/PfxRcd sudah muncul nilai 0, saat ini sudah berganti muncul nilai 1, yang artinya kita menerima 1 route yang diadvertise BGP oleh router lain. 

R1 

R1#sh ip bgp 
BGP table version is 3, local router ID is 12.12.12.1 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
             r RIB-failure, S Stale 
Origin codes: i - IGP, e - EGP, ? - incomplete 


    Network       Next Hop        Metric    LocPrf      Weight   Path 
*> 1.1.1.1/32      0.0.0.0            0                        32768     i 
*>i2.2.2.2/32      12.12.12.2       0           100            0        i 

Selanjutnya kita cek, apakah route tersebut sudah muncul dalam routing tabelnya. 

R1 

R1#sh ip route bgp 
 2.0.0.0/32 is subnetted, 1 subnets 
B 2.2.2.2 [200/0] via 12.12.12.2, 00:10:15 

Sekarang kita tes ping ke route tersebut... 

R1 

R1#ping 2.2.2.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms 

R2

R2#ping 1.1.1.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms


























































LAB 1 FORTIGATE BASIC KONFIG

BASIC KONFIG FORTIGATE     Assalamualaikum Warahmatullahi Wabarakaatuh.....       Yaa...  jadi kali ini saya akan menjelaskan tutorial basic...